﻿
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#">
<head profile="https://gmpg.org/xfn/11">
<script src="//use.edgefonts.net/pt-sans-narrow:n4,n7;pt-sans:n4,i4,n7,i7.js"></script>
<link href='https://fonts.googleapis.com/css?family=Sintony|Open+Sans' rel='stylesheet' type='text/css'>
<link rel="shortcut icon" href="/tdr.ico" type="image/x-icon" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>The Daily Roxette  &raquo; TDR Archive   &raquo; Joyride 30 year anniversary!</title>
<meta name="generator" content="WordPress 5.6.2" /> 
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=yes" />
<script language="JavaScript" type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js"></script>
<link rel="stylesheet" href="/wp-content/themes/tdr_v1.2/style.css" type="text/css" media="screen" />


<link rel="alternate" type="application/rss+xml" title="The Daily Roxette RSS Feed" href="http://www.dailyroxette.com/news/feed" />
<link rel="pingback" href="http://www.dailyroxette.com/xmlrpc.php" />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Daily Roxette &raquo; Joyride 30 year anniversary! Comments Feed" href="http://www.dailyroxette.com/joyride-30-year-anniversary/feed/" />

<script src="//www.googletagmanager.com/gtag/js?id=UA-54617-2" type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" data-cfasync="false">
				var em_version = '6.6.2';
				var em_track_user = true;
				var em_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-54617-2';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( em_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dNDMyYj' : true,
						                    });
					__gtagTracker( 'config', 'UA-54617-2', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.dailyroxette.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tfg_style-css' href='http://www.dailyroxette.com/wp-content/plugins/twitter-facebook-google-plusone-share/tfg_style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='form-manager-css-css' href='http://www.dailyroxette.com/wp-content/plugins/wordpress-form-manager/css/style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='http://www.dailyroxette.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpcdt-public-css-css' href='http://www.dailyroxette.com/wp-content/plugins/countdown-timer-ultimate/assets/css/wpcdt-timecircles.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wprc-style-css' href='http://www.dailyroxette.com/wp-content/plugins/report-content/static/css/styles.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wppa_style-css' href='http://www.dailyroxette.com/wp-content/plugins/wp-photo-album-plus/theme/wppa-style.css?ver=210223-140458' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='http://www.dailyroxette.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://www.dailyroxette.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wp-smart-pagination-css' href='http://www.dailyroxette.com/wp-content/plugins/wp-smart-pagination/wp-smart-pagination.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='exactmetrics-popular-posts-style-css' href='http://www.dailyroxette.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/css/frontend.min.css?ver=6.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='esf-custom-fonts-css' href='http://www.dailyroxette.com/wp-content/plugins/easy-facebook-likebox/frontend/assets/css/esf-custom-fonts.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='esf-insta-frontend-css' href='http://www.dailyroxette.com/wp-content/plugins/easy-facebook-likebox//instagram/frontend/assets/css/esf-insta-frontend.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='esf-insta-customizer-style-css' href='http://www.dailyroxette.com/wp-admin/admin-ajax.php?action=esf-insta-customizer-style&#038;ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='http://www.dailyroxette.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.12' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css' href='http://www.dailyroxette.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.4' type='text/css' media='screen' />
<link rel='stylesheet' id='lightboxStyle-css' href='http://www.dailyroxette.com/wp-content/plugins/lightbox-plus/css/shadowed/colorbox.min.css?ver=2.7.2' type='text/css' media='screen' />
<script type='text/javascript' id='form-manager-js-user-js-extra'>
/* <![CDATA[ */
var fm_user_I18n = {"ajaxurl":"http:\/\/www.dailyroxette.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/wordpress-form-manager/js/userscripts.js?ver=5.6.2' id='form-manager-js-user-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,ra,mp,avi,flv,mpeg,pdf,doc,ppt,xls,jp,png,gif,tiff,bmp,txt","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/www.dailyroxette.com","hash_tracking":"false","ua":"UA-54617-2"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=6.6.2' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='wprc-script-js-extra'>
/* <![CDATA[ */
var wprcajaxhandler = {"ajaxurl":"http:\/\/www.dailyroxette.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/report-content/static/js/scripts.js?ver=5.6.2' id='wprc-script-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/easy-facebook-likebox/frontend/assets/js/imagesloaded.pkgd.min.js?ver=5.6.2' id='imagesloaded.pkgd.min-js'></script>
<script type='text/javascript' id='esf-insta-public-js-extra'>
/* <![CDATA[ */
var esf_insta = {"ajax_url":"http:\/\/www.dailyroxette.com\/wp-admin\/admin-ajax.php","version":"free","nonce":"9f08f77fb6"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/easy-facebook-likebox//instagram/frontend/assets/js/esf-insta-public.js?ver=1' id='esf-insta-public-js'></script>
<link rel="https://api.w.org/" href="http://www.dailyroxette.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.dailyroxette.com/wp-json/wp/v2/posts/1057804" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.dailyroxette.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.dailyroxette.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6.2" />
<link rel="canonical" href="http://www.dailyroxette.com/joyride-30-year-anniversary/" />
<link rel='shortlink' href='http://www.dailyroxette.com/?p=1057804' />
<link rel="alternate" type="application/json+oembed" href="http://www.dailyroxette.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.dailyroxette.com%2Fjoyride-30-year-anniversary%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.dailyroxette.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.dailyroxette.com%2Fjoyride-30-year-anniversary%2F&#038;format=xml" />

<link rel="image_src" href="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg" />


<link type="text/css" rel="stylesheet" href="http://www.dailyroxette.com/wp-includes/js/thickbox/thickbox.css" />
<link type="text/css" rel="stylesheet" href="http://www.dailyroxette.com/wp-content/plugins/wp-auctions/styles/default/color.css" />


<style type="text/css">
</style>




<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="The Daily Roxette" />
<meta property="og:title" content="Joyride 30 year anniversary!" />
<meta property="og:url" content="http://www.dailyroxette.com/joyride-30-year-anniversary/" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Today is no ordinary day. No today it&#039;s 30 years ago &quot;Joyride&quot; was released. And what a smash it was!" />
<meta property="og:image" content="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg" />
<meta property="og:image:url" content="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg" />
<meta property="article:published_time" content="2021-02-27T11:47:23+01:00" />
<meta property="article:modified_time" content="2021-02-27T21:31:18+01:00" />
<meta property="og:updated_time" content="2021-02-27T21:31:18+01:00" />
<meta property="article:section" content="TDR:Editorial" />
<meta property="article:section" content="TDR:Exclusive" />
<meta property="article:section" content="TDR:Roxette" />
<meta property="article:author" content="thomas.evensson" />

<meta itemprop="name" content="Joyride 30 year anniversary!" />
<meta itemprop="headline" content="Joyride 30 year anniversary!" />
<meta itemprop="description" content="Today is no ordinary day. No today it&#039;s 30 years ago &quot;Joyride&quot; was released. And what a smash it was!" />
<meta itemprop="image" content="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg" />
<meta itemprop="datePublished" content="2021-02-27" />
<meta itemprop="dateModified" content="2021-02-27T21:31:18+01:00" />
<meta itemprop="author" content="Thomas Evensson" />
 

<meta name="twitter:title" content="Joyride 30 year anniversary!" />
<meta name="twitter:url" content="http://www.dailyroxette.com/joyride-30-year-anniversary/" />
<meta name="twitter:description" content="Today is no ordinary day. No today it&#039;s 30 years ago &quot;Joyride&quot; was released. And what a smash it was!" />
<meta name="twitter:image" content="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@@tevensso" />




<script>

	  $(document).ready(function(){

		  $("ul li ul li:first-child")

		  .css("padding-top", "10px")

	  });

	</script> <script type="text/javascript">   function toggle(control){     var elem = document.getElementById(control);     if(elem.style.display == "none"){      elem.style.display = "block";     }else{          elem.style.display = "none";       }   }</script>

<script>
$(document).ready(function() {
  $('[href*="Book2018_lo.pdf"]').click(function() { ga('send', 'event', 'Download', 'Click', 'TourBook2018LoResDownload', '0'); });
  $('[href*="Book2018_hi.pdf"]').click(function() { ga('send', 'event', 'Download', 'Click', 'TourBook2018HiResDownload', '0'); });
});
</script>
<link rel='stylesheet' id='jquery_ui_css-css' href='https://cdnjs.cloudflare.com/ajax/libs/jqueryui/1.11.4/jquery-ui.css?ver=5.6.2' type='text/css' media='all' />
</head>
<body>
<div id="fb-root"></div><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0&appId=133902596691047"></script>
<div id="header">
<div class="headerblank">
<div id="hdrContainer">
<div id="hdr_right">
Sunday, February 28, 2021
</div>
<div id="hdr_middle">
<b>THE DAILY COMMENTS ON GLOBAL ENTERTAINMENT AND POP CULTURE</b>
</div>
<div id="hdr_left">
Established in 1997
</div>
</div>
<a href="http://www.dailyroxette.com"><img src="http://www.dailyroxette.com/images/blank.gif" style="height:203px;">
</a>
</div>
<div id="navbar" class="navbar">
<nav id="site-navigation" class="navigation main-navigation" role="navigation">
<div class="menu-mainmenu-container"><ul id="menu-mainmenu" class="nav-menu"><li id="menu-item-13936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13936"><a href="http://www.dailyroxette.com">Home</a></li>
<li id="menu-item-1056382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1056382"><a href="http://www.dailyroxette.com/my-marie/">My Marie</a></li>
<li id="menu-item-1056309" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1056309"><a href="http://www.dailyroxette.com/remembrance-book-for-marie-fredriksson/">Remembrance book for Marie Fredriksson</a></li>
<li id="menu-item-2993" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2993"><a href="http://www.dailyroxette.com/archives/">TDR archives</a>
<ul class="sub-menu">
<li id="menu-item-180739" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180739"><a href="http://www.dailyroxette.com/archives/">Overview</a></li>
<li id="menu-item-163926" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-163926"><a href="http://www.dailyroxette.com/news/">TDR News</a></li>
<li id="menu-item-163823" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-163823"><a href="http://www.dailyroxette.com/timeline/">Roxette timeline</a></li>
<li id="menu-item-164306" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164306"><a href="http://www.dailyroxette.com/history/">Today&#8217;s history</a></li>
</ul>
</li>
<li id="menu-item-124971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-124971"><a href="http://www.dailyroxette.com/events/">Live &#038; Tour</a>
<ul class="sub-menu">
<li id="menu-item-163824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163824"><a href="http://www.dailyroxette.com/tours-and-concerts/">Tourography</a></li>
<li id="menu-item-124973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124973"><a href="http://www.dailyroxette.com/2014-roxette-tour/">30th Anniversary Tour</a></li>
<li id="menu-item-138576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138576"><a href="http://www.dailyroxette.com/live/">TDR Live reports</a></li>
<li id="menu-item-124975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124975"><a href="http://www.dailyroxette.com/submit_event/">Submit an event!</a></li>
<li id="menu-item-180855" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180855"><a href="http://www.dailyroxette.com/fantastic-the-video/">FANtastic</a></li>
<li id="menu-item-1041315" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1041315"><a href="http://www.dailyroxette.com/xmas2018/">TDR presents: Per Gessle&#8217;s Roxette&#8217;s Unofficial Tour Book 2018</a></li>
</ul>
</li>
<li id="menu-item-163925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-163925"><a href="http://www.dailyroxette.com/music/">Music</a>
<ul class="sub-menu">
<li id="menu-item-163825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163825"><a href="http://www.dailyroxette.com/discography/">Discography</a></li>
<li id="menu-item-163826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163826"><a href="http://www.dailyroxette.com/lyrics-cat/">Lyrics</a></li>
<li id="menu-item-1056149" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1056149"><a href="http://www.dailyroxette.com/gt40-for-40-gyllene-tiders-40-best-songs-according-to-tdr/">GT40 for 40: Gyllene Tider&#8217;s 40 best songs, according to TDR</a></li>
</ul>
</li>
<li id="menu-item-2994" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2994"><a href="http://www.dailyroxette.com/contact/">About us</a>
<ul class="sub-menu">
<li id="menu-item-2996" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2996"><a href="http://www.dailyroxette.com/reporter/">Be a good reporter!</a></li>
</ul>
</li>
</ul></div>
</nav>
</div>
</div>
<div id="container">
<div id="content" class="narrowcolumn">
<div class="content_left">
<br><br>
<div style="max-height:54px;overflow:hidden;">
<a href="/roxette">
<div class="topbox_color" style="background-color:#cc0022;margin-top:26px;margin-right:3px;height:27px;width:100px;float:left;">
<span style="font-family: pt-sans-narrow, sans-serif; font-size:16px; font-weight:bold;  color:#fff;  margin-left:10px; padding-left:10px;"> Roxette </span>
</div>
</a>
<a href="/editorial"> <div class="topbox_color" style="background-color:#810648;margin-top:26px;margin-right:3px;height:27px;width:100px;float:left;"> <span style="font-family: pt-sans-narrow, sans-serif; font-size:16px; font-weight:bold;  color:#fff;  margin-left:10px; padding-left:10px;"> Editorial </span> </div> </a> <a href="/exclusive"> <div class="topbox_color" style="background-color:#810648;margin-top:26px;margin-right:3px;height:27px;width:100px;float:left;"> <span style="font-family: pt-sans-narrow, sans-serif; font-size:16px; font-weight:bold;  color:#fff;  margin-left:10px; padding-left:10px;"> Exclusive </span> </div> </a>
</div>
<div class="post_tdr_single_image">
<div class="post_tdr_single_featured">
<img width="1200" height="800" src="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30.jpg 1200w, http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30-874x583.jpg 874w, http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30-426x284.jpg 426w, http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30-768x512.jpg 768w, http://www.dailyroxette.com/wp-content/uploads/2021/02/joyride_30-300x200.jpg 300w" sizes="(max-width: 1200px) 100vw, 1200px" />
</div>
</div>
<div class="single_full" style="background-color:#fafafa;">
<div class="posttitle_tdr_single">
<br>Joyride 30 year anniversary!
</div>
<br>
</div>
<div class="bottomcontainerBox" style="border:1px solid #808080;background-color:#F0F4F9;">
<div style="float:left; width:160px;padding-right:10px; margin:4px 4px 4px 4px;height:30px;">
<iframe src="https://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.dailyroxette.com%2Fjoyride-30-year-anniversary%2F&amp;layout=button_count&amp;show_faces=false&amp;width=160&amp;action=like&amp;font=verdana&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:160px; height:21px;"></iframe></div>
<div style="float:left; width:120px;padding-right:10px; margin:4px 4px 4px 4px;height:30px;">
<a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.dailyroxette.com/joyride-30-year-anniversary/" data-text="Joyride 30 year anniversary!" data-count="horizontal" data-via="dailyroxette"></a>
</div>
</div><div style="clear:both"></div><div style="padding-bottom:4px;"></div><div class="single_full">
<div class="single_left">
<div class="post_tdr_single" id="post-1057804">
<b><br>
Today is no ordinary day. No today it's 30 years ago "Joyride" was released. And what a smash it was!<br> </b>
<p>I remember standing by the radio waiting for the premiere of the single. They kept talking about it all morning, I don&#8217;t remember anymore, but I think the premiere was at 11am. I heard it and I&#8217;d like to say the whole world stopped, but I was a bit underwhelmed to be honest. &#8220;Was this it??&#8221; After &#8220;The Look,&#8221; &#8220;Dressed for Success&#8221; and &#8220;Listen to Your Heart&#8221;?</p>
<p>Of course I was wrong, and after getting the 7&#8243; singles, four of them with different sleeves, the CD single and the 12&#8243; remix single with the MagicFriends mix, I totally changed my mind, and after 30 years it still is a favorite of mine. Who can forget the guitar lick, most likely composed by the almighty MP? And not to mention the whistling. The Swedish 7&#8243; has an engraving in the center: &#8220;Was it really necessary to whistle??&#8221;</p>
<p>&#8220;<a href="http://www.dailyroxette.com/joyride-7%e2%80%b3/">Joyride</a>&#8221; was a super hit all over the world. It sold Gold in Canada, Germany and Austria, while Platinum in Sweden and Australia. It was #1 in at least 17 countries, of which France wasn&#8217;t one of them, where it peaked at #39&#8230; merci beaucoup froglegs.</p>
<p>The chorus &#8220;Hello you fool, I love you!&#8221; was inspired by a note Per got from his wife Åsa and the title comes from a Paul McCartney quote about writing songs with John Lennon being &#8220;a long joyride.&#8221;</p>
<p>The Vancouver Canucks used the song in the 1994 Stanley cup playoffs when entering the ice!</p>
<p>Some comments about the song: (and our friend Brendon calls the Ferrari Dino a Corvette, but we&#8217;ll let it slide this time&#8230;)</p>
<p><em>AllMusic editor Bryan Buss described the song as a &#8220;chanting carnival&#8221; in his review of the Joyride album. Larry Flick from Billboard described it as a &#8220;playful pop/rock ditty with a catchy chorus that is destined to make a quick sprint up the charts.&#8221; Jim Farber from Entertainment Weekly noted that &#8220;they blithely toss a bit of whistling into &#8220;Joyride&#8221;, next to some psychedelic Beatles-like flourishes.&#8221; Dave Sholin from the Gavin Report wrote, &#8220;Plenty of reason for joy in Top 40 land as Per Gessle and Marie Fredriksson deliver the first of a new batch of songs. Wisely, the Swedish duo retain &#8220;Look Sharp&#8221; producer Clarence Ofwerman, and, once again it&#8217;s clear all three understand the way to a pop music fan&#8217;s heart. Roxette has re-applied that happy, feelgood formula to making mass appeal records, and it&#8217;s earned them instant recognition and remarkable chart success. This title track from their new album is certain to not only meet everyone&#8217;s expectations, but surpass them.&#8221; Music &amp; Media stated that the song &#8220;is a perfect example of their pop sensibilities.&#8221;</em></p>
<p><em>Brendon Veevers from Renowned for Sound commented, &#8220;There isn&#8217;t a soul alive who cannot say they don’t love this track – Roxette fan or not. It&#8217;s pop at its finest and the video is equally as memorable; the band speeding down a U.S highway, playing guitar on top of a red Corvette. &#8220;Rolling Stones J.D. Considine said that the song is &#8220;decked out in a glossy, Sgt. Pepper-style arrangement&#8221;. Mark Frith from Smash Hits labeled it as a &#8220;over-the-top&#8221; pop song, &#8220;with catchy choruses that remind you slightly of those other musical Swedes, Abba.&#8221; A writer for Cleveland.com ranked &#8220;Joyride&#8221; the 46th best Billboard Hot 100 number one of the 1990s, saying: &#8220;Even more so than the group&#8217;s biggest hit, &#8216;It Must Have Been Love,&#8217; &#8216;Joyride&#8217; showed off Per Gessle&#8217;s ability to craft fantastic pop-rock songs. The song&#8217;s pop spirit and rock swagger mesh seamlessly.&#8221;</em></p>
<p>And who can forget the amazing video, shot in the desert outside of Los Angeles?&nbsp;</p>
<div class="video-container"><iframe title="Roxette - Joyride (Official Video)" width="874" height="656" src="https://www.youtube.com/embed/xCorJG9mubk?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>

</div>
</div>
<div class="single_right">
<div class="post_author">
</div>


<div class="tdrbox_title" style="text-transform:none;font-size:120%;font-weight:bold;height:26px;">
<span style="color:#ee1e1e;font-size:110%;">&ensp; &#9733; </span> The author:
</div>
<div class="topbox_color" style="background-color:#ae0404;"></div>
<table style="background-color:#e5e5ec;display:inline-block;width:100%;"><tr><td style="width:90px;">
<a href="http://www.dailyroxette.com/author/tevensso/">
<div style="float:left;margin-right:8px;margin-bottom:8px;">
<img src="http://www.dailyroxette.com/wp-content/uploads/2018/02/tdr-96x96.jpg" width="80" height="80" alt="Thomas Evensson" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo" />
</div></a>
</td><td>
<div style="clear:both;font-size:80%;margin-bottom:20px;">
<a href="http://www.dailyroxette.com/author/tevensso/">
<span style="font-size:120%;">
<b>Thomas Evensson</b>
</span>
</a>

</div> </td></tr></table>
<br><br>
<div class="tdrbox_title" style="text-transform:none;font-size:120%;font-weight:bold;height:26px;">
<span style="color:#ee1e1e;font-size:110%;">&ensp; &#9733; </span> Publishing date:
</div>
<div class="topbox_color" style="background-color:#ae0404;"></div>
<div class="tdrbox_title_right"><br>
<span style="font-size:120%;">
<a href="http://www.dailyroxette.com/2021/02/27/">
<b>February 27th, 2021</b><br>
</a>
<br><br> Internal reference code for TDR's Good Reporters: <b>[tdr 1057804] </b><br><br> This article was posted here on TDR in these categories: <br><br> <a href="http://www.dailyroxette.com/editorial/" rel="category tag">TDR:Editorial</a>, <a href="http://www.dailyroxette.com/exclusive/" rel="category tag">TDR:Exclusive</a>, <a href="http://www.dailyroxette.com/roxette_/" rel="category tag">TDR:Roxette</a>. <br><br>
</span>
</div>
<div class="tdrbox_title" style="text-transform:none;font-size:120%;font-weight:bold;height:26px;">
<span style="color:#ee1e1e;font-size:110%;">&ensp; &#9733; </span> Read more about...
</div>
<div class="topbox_color" style="background-color:#ae0404;"></div>
<div style="clear:both;background-color:#8e5694;display:inline-block;width:100%;margin-top:1px;"> <a href="/roxette" style="color:#fff; text-decoration:none;"> <img src="http://www.dailyroxette.com/wp-content/themes/tdr_v1.2/images/cat_rox.jpg" style="float:left;width:75px;height:55px;margin-right:18px;margin-bottom:0px;"> <span style="font-size:120%;font:white; "><br><b> Roxette </b> </span> </a> </div>
</div>
</div> 
<div class="tdrbox_title_bottom">

</div>
<br><br>
<div id="disqus_thread"></div>
<div style="font-size:8px"><div class="wprc-container green-colorscheme">
<button type="button" class="wprc-switch">Report an error...</button>
<div class="wprc-content">
<div class="wprc-message">
</div>
<div class="wprc-form">
<div class="left-section">
<li class="list-item-reason">
<label for="input-reason-1057804">Issue: <span class="required-sign">*</span></label><br />
<select id="input-reason-1057804" class="input-reason">
<option>Broken Links</option>
<option>Missing images</option>
<option>Factual errors</option>
<option>Copyright Infringment</option>
<option>Other</option>
</select>
</li>
<li class="list-item-name">
<label for="input-name-1057804">
Your Name:
<span class="required-sign">*</span> </label><br />
<input type="text" id="input-name-1057804" class="input-name wprc-input" />
</li>
<li class="list-item-email">
<label for="input-email-1057804">
Your Email:
<span class="required-sign">*</span> </label><br />
<input type="text" id="input-email-1057804" class="input-email wprc-input" />
</li>
</div>
<div class="right-section">
<li class="list-item-details">
<label for="input-details-1057804">
Details:
<span class="required-sign">*</span> </label><br />
<textarea id="input-details-1057804" class="input-details wprc-input"></textarea>
</li>
</div>
<div class="clear"></div>
<input type="hidden" class="post-id" value="1057804">
<button type="button" class="wprc-submit">Submit Report</button>
<img class="loading-img" style="display:none;" src="http://www.dailyroxette.com/wp-content/plugins/report-content/static/img/loading.gif" />
</div>
</div>
</div>` </div><br><br>
 </div></div>
<div id="footer">

<p>
<br><b>The Daily Roxette</b> has 24883 articles online. Use our constantly growing archive to find out more about Roxette, Gyllene Tider, Per Gessle, Marie Fredriksson, Son of a Plumber and more.

</p>
</div>
</div>
<script type='text/javascript' src="https://platform.twitter.com/widgets.js?ver=5.6.2" id='twitter_facebook_share_twitter-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"dailyroxette"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.21' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"1057804 http:\/\/www.dailyroxette.com\/?p=1057804","disqusShortname":"dailyroxette","disqusTitle":"Joyride 30 year anniversary!","disqusUrl":"http:\/\/www.dailyroxette.com\/joyride-30-year-anniversary\/","postId":"1057804"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.21' id='disqus_embed-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.dailyroxette.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/lightbox-plus/js/jquery.colorbox.1.5.9-min.js?ver=1.5.9' id='jquery-colorbox-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.dailyroxette.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/wp-auctions/wp_auctionsjs.php?ver=5.6.2' id='wp_auction_AJAX-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1' id='jquery-form-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b' id='jquery-masonry-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.12.1' id='jquery-ui-resizable-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id='jquery-ui-draggable-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/controlgroup.min.js?ver=1.12.1' id='jquery-ui-controlgroup-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/checkboxradio.min.js?ver=1.12.1' id='jquery-ui-checkboxradio-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/button.min.js?ver=1.12.1' id='jquery-ui-button-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.12.1' id='jquery-ui-dialog-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/plugins/wp-photo-album-plus/js/wppa-all.js?ver=210219-142850' id='wppa-js'></script>
<script type='text/javascript' src='http://www.dailyroxette.com/wp-content/uploads/wppa/dynamic/wppa-init.en.js?ver=89' id='wppa-init-js'></script>

<script type="text/javascript">
jQuery(document).ready(function($){
  $("a[rel*=lightbox]").colorbox({initialWidth:"30%",initialHeight:"30%",maxWidth:"90%",maxHeight:"90%",opacity:0.8});
});
</script>

<script>
/* START PHOTO sc and TynyMce fe vars from p-f*/
wppaImageDirectory = "http://www.dailyroxette.com/wp-content/plugins/wp-photo-album-plus/img/";
wppaPhotoDirectory = "http://www.dailyroxette.com/wp-content/uploads/wppa/";
wppaNoPreview = "No Preview available";
wppaTxtProcessing = "Processing...";
wppaTxtDone = "Done!";
wppaTxtErrUnable = "ERROR: unable to upload files.";
wppaOutputType = "-none-";
wppaShortcodeTemplate = "&lt;div style=&quot;font-size:0;line-height:0;&quot; &gt;&lt;img id=&quot;ph-483-100&quot; src=&quot;http://www.dailyroxette.com/wp-content/uploads/wppa/483.jpg?ver=8&quot;  alt=&quot;Photo 483&quot;  title=&quot;Photo 483&quot;  style=&quot;width:100%;margin:0;&quot; /&gt;&lt;/div&gt;";
wppaShortcodeTemplateId = "483.jpg";
/* END PHOTO and TynMce */
/* WPPA+ START Page/language dependant data */
wppaImageDirectory = "http://www.dailyroxette.com/wp-content/plugins/wp-photo-album-plus/img/";
wppaWppaUrl = "http://www.dailyroxette.com/wp-content/plugins/wp-photo-album-plus";
wppaIncludeUrl = "http://www.dailyroxette.com/wp-includes";
wppaAjaxUrl = "http://www.dailyroxette.com/wp-content/plugins/wp-photo-album-plus/wppa-ajax-front.php";
wppaUploadUrl = "http://www.dailyroxette.com/wp-content/uploads/wppa";
wppaIsIe = false;
wppaIsSafari = false;
wppaSlideshowNavigationType = "icons";
wppaAudioHeight = 28;
wppaFilmThumbTitle = "Double click to start/stop slideshow running";
wppaClickToView = "Click to view";
wppaLang = "en";
wppaVoteForMe = "Vote for me!";
wppaVotedForMe = "Voted for me";
wppaDownLoad = "Download";
wppaSlideShow = "Slideshow";
wppaPhoto = "Photo";
wppaOf = "of";
wppaNextPhoto = "Next photo";
wppaPreviousPhoto = "Previous photo";
wppaNextP = "Next";
wppaPrevP = "Prev.";
wppaAvgRating = "Average&nbsp;rating";
wppaMyRating = "My&nbsp;rating";
wppaAvgRat = "Avg.";
wppaMyRat = "Mine";
wppaDislikeMsg = "You marked this image as inappropriate.";
wppaStart = "Start";
wppaStop = "Stop";
wppaPleaseName = "Please enter your name";
wppaPleaseEmail = "Please enter a valid email address";
wppaPleaseComment = "Please enter a comment";
wppaProcessing = "Processing...";
wppaDone = "Done!";
wppaUploadFailed = "Upload failed";
wppaServerError = "Server error.";
wppaGlobalFsIconSize = "32";
wppaFsFillcolor = "#999999";
wppaFsBgcolor = "transparent";
wppaFsPolicy = "lightbox";

/* WPPA+ END Page/language dependant data */

</script>

<script type="text/javascript">
var sc_project=10096296; 
var sc_invisible=1; 
var sc_security="a1896019"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "https://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="site stats"
href="https://statcounter.com/" target="_blank"><img
class="statcounter"
src="https://c.statcounter.com/10096296/0/a1896019/1/"
alt="site stats"></a></div></noscript>

</body>
</html>
